Ant error – tools.jar missing

Migrated. Originally posted: 2008-04-02

If you have ant installed, and it runs at all, it means you have java installed. If, however, you are on a Debian-based system, you may still get the error that says “tools.jar” is missing.

It turns out this means you need some more ant stuff installed.

Try the following:

-> sudo apt-get install java-gcj-compat-dev

This will probably install several packages that it requires. One of them provides tools.jar, or some reasonable facsimile. It let me run Ant without errors anyway.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s